Wunderlist Support Website currently unavailable
Incident Report for Wunderlist
Resolved
This incident has been resolved.
Posted 11 months ago. Jul 24, 2018 - 16:14 CEST
Identified
The Wunderlist Support Center on https://support.wunderlist.com is currently not available. We are working on getting this issue resolved as quickly as possible.

This does not affect the Wunderlist App itself.
Posted 11 months ago. Jul 24, 2018 - 13:20 CEST