Unexpected Issues with Sync
Incident Report for Wunderlist
Resolved
This incident has been resolved.
Posted over 3 years ago. Aug 30, 2014 - 04:04 CEST
Investigating
We're experiencing some unexpected sync issues. We hope to have service up soon.
Posted over 3 years ago. Aug 30, 2014 - 03:33 CEST