Mail to Wunderlist temporarily unavailable
Incident Report for Wunderlist
Resolved
This incident has been resolved.
Posted about 2 years ago. Nov 10, 2015 - 14:41 CET
Investigating
We've identified an issue with our Mail to Wunderlist Service. Forwarded emails to your me@wunderlist.com Inbox are currently bouncing, but not to worry! We'll get it back up and running as soon as possible. Hold off on forwarding your emails until we've given the thumbs up to do so again <3
Posted about 2 years ago. Nov 10, 2015 - 10:07 CET