Service Update
Incident Report for Wunderlist
Resolved
This incident has been resolved.
Posted about 3 years ago. Oct 02, 2014 - 18:10 CEST
Identified
We’re investigating an unexpected performance problem with Wunderlist’s servers.

We'll be posting an update once we've identified the exact problem - sorry about the productivity interruption!
Posted about 3 years ago. Oct 02, 2014 - 17:08 CEST