Problems with Mail to Wunderlist
Incident Report for Wunderlist
Resolved
This incident has been resolved.
Posted about 2 years ago. Jan 05, 2015 - 16:33 CET
Identified
Our feature Mail to Wunderlist is currently not working because of issues with our email host (http://status.df.eu/)
We hope this issue gets resolved as soon as possible. Thank you very much for your patience.
Posted about 2 years ago. Jan 05, 2015 - 15:31 CET