Unexpected down-time
Incident Report for Wunderlist
Resolved
This incident has been resolved.
Posted almost 2 years ago. Jan 28, 2016 - 11:57 CET
Investigating
Hi, we've just identified an issue with logging in to your Wunderlist account or with creating a new one. We're working to get that back up and running ASAP and are very sorry for any inconvenience in the meantime.
Posted almost 2 years ago. Jan 28, 2016 - 11:27 CET