Issue with Forgot Password Option
Incident Report for Wunderlist
Resolved
This incident has been resolved.
Posted over 1 year ago. Sep 28, 2015 - 10:20 CET
Identified
We are currently experiencing issues with the Forgot Password option in Wunderlist, which causes the Reset Password emails not getting send out. We've identified the problem and work on getting it resolved as fast as possible. Apologies for the inconvenience.
Posted over 1 year ago. Sep 28, 2015 - 09:39 CET