Problems with Mail to Wunderlist
Incident Report for Wunderlist
Resolved
This incident has been resolved.
Posted 7 months ago. Jan 24, 2018 - 14:27 CET
Investigating
We are currently facing problems with the Mail to Wunderlist feature. Our engineering team is working on resolving this issue as quickly as possible.

We apologize for any troubles this may cause you.
Posted 7 months ago. Jan 24, 2018 - 11:16 CET