Beta Download page currently not working
Incident Report for Wunderlist
Resolved
This incident has been resolved.
Posted over 2 years ago. Feb 17, 2015 - 12:12 CET
Identified
Our Wunderlist Beta download page on beta.6wunderkinder.com is currently not working. We are looking into the issue and try to fix it as soon as possible.
Posted over 2 years ago. Feb 16, 2015 - 11:26 CET