Tasks not loading
Incident Report for Wunderlist
Resolved
You should be able to access all of your tasks now again normally. Thanks again for bearing with us while we got it sorted!
Posted 6 months ago. Apr 10, 2018 - 18:57 CEST
Investigating
Tasks may not be loading or syncing to your devices. We're working to identify the cause and get everything back up and running normally again. Thanks for your patience and apologies for any inconvenience this may cause.
Posted 6 months ago. Apr 10, 2018 - 17:48 CEST