Interruption to sync
Incident Report for Wunderlist
Resolved
This incident has been resolved.
Posted over 1 year ago. Sep 08, 2015 - 01:37 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted over 1 year ago. Sep 07, 2015 - 20:23 CEST
Investigating
We are currently investigating this issue.
Posted over 1 year ago. Sep 07, 2015 - 20:03 CEST