Intermittent sync issues
Incident Report for Wunderlist
Resolved
This incident has been resolved.
Posted over 2 years ago. Sep 07, 2015 - 18:47 CEST
Investigating
Some users may be seeing delays in sync. We're investigating.
Posted over 2 years ago. Sep 07, 2015 - 18:32 CEST