Mail To Wunderlist temporarily down
Incident Report for Wunderlist
Resolved
This incident has been resolved.
Posted almost 2 years ago. Oct 23, 2015 - 18:06 CEST
Identified
We've identified an issue with our Mail to Wunderlist Service. Forwarded emails to your me@wunderlist.com Inbox are currently bouncing, but not to worry! We'll get it back up and running as soon as possible. Hold off on forwarding your emails until we've given the Go to do so again <3
Posted almost 2 years ago. Oct 23, 2015 - 17:20 CEST